Uzbl

Tasklist

FS#144 - sh is not escaping characters correctly

Attached to Project: Uzbl
Opened by Nicolau Leal Werneck (nlw0) - 2009-12-02 02:09:43 PM
Last edited by Ben Boeckel (mathstuf) - 2014-03-06 07:25:02 AM
Task Type Bug Report
Category uzbl-core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have not been able to use the sh configuration command with escaped characters. For example, sh 'echo \\' will not print '\' on the screen. It seems all backslashes are being simply ignored... No example configuration file I have tested with commands that needed escaped quotes has worked (i.e. awesome integration examples).
This task depends upon

Closed by  Ben Boeckel (mathstuf)
2014-03-06 07:25:02 AM
Reason for closing:  Not a bug
Comment by Anonymous Submitter - 2010-03-21 02:57:36 PM
I suspect this is because you aren't using enough \\\\\\'s

After a few passes through uzbl-core its easy to lose a lot of backslashes.
Comment by Noel Maersk (veox) - 2012-12-13 06:01:05 PM
I have determined it needs 8 backslashes. That is 2^3. A half is consumed by echo. What are the other two? Config parser and sh?
Comment by Ben Boeckel (mathstuf) - 2013-07-02 05:18:29 AM
> What are the other two? Config parser and sh?

Likely.

Loading...