Uzbl

Tasklist

FS#167 - gmail download attachments do not work

Attached to Project: Uzbl
Opened by Vytautas (vytautas1987) - 2009-12-26 11:00:26 AM
Last edited by Brendan Taylor (bct) - 2012-11-25 10:50:43 PM
Task Type Bug Report
Category uzbl-browser & sample material
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

gmail download attachments do not work.
This task depends upon

Closed by  Brendan Taylor (bct)
2012-11-25 10:50:43 PM
Reason for closing:  Works for me
Comment by Ben Rich (mrbrich) - 2010-02-09 07:07:17 PM
I can confirm this. The result is a file in the home directory with a long name beginning with "ServiceLogin\?service\=mail..." the contents of which are HTML that looks like it could be from the GMail login page.
Comment by Anonymous Submitter - 2010-03-21 03:27:24 PM
This will be the case for two reasons.

You aren't giving the location of the cookies.txt file to wget and you need to pass the '--content-disposition' option to wget to get a meaningful filename.
Comment by Henry Hu (henryhu) - 2010-04-27 01:26:33 PM
I can confirm this too. The result is the same as mrbrich.
Comment by Israel Levin (israellevin1) - 2010-05-01 10:42:18 PM
In the current version (Commit: 2113fcc2eba5611075ff4fae9f5098bcbf83d77d) I am able to right-click the "download" link, chose "save linked file", and get a (zenity?) dialog that tells me "all updates are complete".

I have no idea where that dialog is coming from, and why it considers downloading an attachment to be an update, but the file does get downloaded perfectly to my home dir - right name and all.

If I left-click the "download" link I just get a refresh of the entire page. Still buggy, but usable.
Comment by Ben Boeckel (mathstuf) - 2011-04-14 04:10:49 AM
The latest release uses webkit's built-in download tool. This should work properly for authenticated downloads (such as gmail). Could you try the latest release?

Loading...