Uzbl

Tasklist

FS#285 - uzbl is not using flash 64-bit

Attached to Project: Uzbl
Opened by Dennis Hodapp (thehodapp) - 2011-10-10 07:44:46 PM
Last edited by Ben Boeckel (mathstuf) - 2014-03-06 06:07:10 AM
Task Type Bug Report
Category uzbl-core
Status Closed
Assigned To No-one
Operating System Linux
Severity Medium
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

using git-experimental 2011.10.01-49-ga580e31 on Arch linux.

Flash is not working after the update to version 11 which is 64-bit. I'm specifically using flashplugin 11.0.1.152-1. I believe the problem is caused by the upgrade from 32-bit to 64-bit.
This task depends upon

Closed by  Ben Boeckel (mathstuf)
2014-03-06 06:07:10 AM
Reason for closing:  Won't fix
Additional comments about closing:  WebKit1+GTK3 == no flash. Nothing we can do. Either use GTK2 or help implement complete WebKit2 support (contact me on IRC for the TODO list).
Comment by Edwin (BlackEdder) - 2011-12-06 10:55:05 AM
I have the same issue. After upgrading to flash 11 (under gentoo) uzbl crashes on many sites. Before this change uzbl+flash was working fine (using flash 11+nspluginwrapper).
Comment by Noel Maersk (veox) - 2013-01-03 01:02:02 PM
This is still the case with uzbl-git. Works OK with stable, though. Is this a uzbl or webkit issue?
Comment by Brendan Taylor (bct) - 2013-01-05 09:18:38 PM
Typically I'd blame this on webkit. Are the stable and -git packages built against the same version of webkit?
Comment by Noel Maersk (veox) - 2013-01-06 01:25:03 AM
In my case, stable was/is built against WebKit 2, and with -git I use WebKit 3. I could try WebKit 2 if I have time, I think I already did (a long time ago), and it didn't work.
Comment by Noel Maersk (veox) - 2013-01-08 09:54:52 AM
STABLE: flash works
-----
uzbl 2012.05.14-2
webkitgtk2 1.10.2-1
gtk2 2.24.14-1
flashplugin 11.2.202.258-1

GIT+WEBKITGTK2: cannot compile
-----
See https://aur.archlinux.org/packages/uzbl-git/
mathstuf's dev/update-webkit-options has same.
Could open bug report if it's not just me.

GIT+WEBKITGTK3: doesn't work
-----
uzbl 20130108-1
webkitgtk3 1.10.2-1
gtk3 3.6.4-1
flashplugin 11.2.202.258-1

Note: 'webkitgtk3' depends on both 'gtk2' and 'gtk3' (Arch Linux x86_64).

Loading...